Google

挙式VR 伊達政宗 編 Wedding VR : Masamune

1 / 6
2 / 6
3 / 6
4 / 6
5 / 6
6 / 6
Region GLOBAL
Platform STEAM
INSTANT DELIVRY

PRICE
200
$7.99 100% OFF
Live Stock Report You receive your product instantly.
Additional information
Release date
Mar 8, 2018
Languages
German, Spanish, French, English, Italian

Instructions to activate 挙式VR 伊達政宗 編 Wedding VR : Masamune steam key free

(1) Launch Steam and log into your Steam account. (2) Click the Games Menu. (3) Choose Activate a Product on Steam. (4) Follow the onscreen instructions to activate 挙式VR 伊達政宗 編 Wedding VR : Masamune key. After successful code verification go to the "MY GAMES" tab and start downloading.
Recommended products
Description

About this game: 挙式VR 伊達政宗 編 Wedding VR : Masamune free steam key

挙式VR 伊達政宗 編 Wedding VR : Masamune steam cd key free on SteamGateways. Free steam keys. CD Keys Gift. Instant download. Free steam games. Instant delivery 24/7. Free Codes & Giveaways. 挙式VR 伊達政宗 編 Wedding VR : Masamune cd key free

挙式VR 伊達政宗 編 Wedding VR : Masamune key free

The happy-full VR experience comes to Oculus Rift! This much-talked-about VR experience is now playable in the palm of your hand! ■Feel as if hes right in front of you! The groom, Date Masamune, is waiting you in the church. It feels as if you could reach out and touch him... Experience the world of Samurai Love Ballad like never before! ■Story You are in a church wearing a wedding dress. He has waiting you. He walks toward you. Then he says "Lets start our wedding ceremony". Youll had a surprise experience with a special scene!! ■Feature - Multi Ending You choice the answer in the ceremony. It makes the ending different. ■English/Japanese Hes voice is japanese both of the language mode. In English mode, the caption of English is displayed.

System requirements
Windows Requirements
  • OS: Windows 7 or greater
  • Processor: Intel i5-4590 equivalent or greater
  • Memory: 8 GB RAM
  • Graphics: NVIDIA GTX 970 / AMD 290 equivalent or greater
  • Storage: 1 GB available space
Mac Requirements
Not available.
Linux Requirements
Not available.